Desktop Sessions Expiring after 4 hours

Incident Report for Lake Tails Grooming Solutions

Postmortem

It was discovered that, when sending token refresh requests from the desktop application to the server, the server was attempting to verify that the hardware id and session token were both active in a current session, however, the data that the server was attempting to check the database with had already been decrypted. Redis' cache was able to supply a seemingly normal amount of time during testing for this problem to not occur, but as soon as the cache ran out and the data had to be pulled from the external database, it was attempting to find a decrypted value in the database where all the values were encrypted. The solution to this problem was to store hardware ids in the database decrypted. While the id is unique to your system itself, it does not contain any information that is sensitive and is purely used as an extra step in license verification, and even if someone held both the decrypted hardware id and refresh token, they theoretically would be unable to gain unauthorized access to the program due to additional security measures in place. Incidents like these in the close beta release of the program are bound to occur due to the lack of limited knowledge before opening the doors for faults. We are constantly improving our systems, and we appreciate your patience and feedback.

Posted Feb 25, 2025 - 23:05 EST

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 22:55 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2025 - 22:26 EST

Update

We are continuing to work on a fix for this issue while ensuring the efficiency of the authentication process.
Posted Feb 25, 2025 - 21:36 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 25, 2025 - 20:58 EST
This incident affected: Lake Tails Grooming Solutions (Authentication).