Facebook Authentication Down

Incident Report for Lake Tails Grooming Solutions

Update

We are aware of an issue with Facebook Authentication being down. This is due to Meta's decision to terminate our page without reason. This service will remain down and inaccessible for the foreseeable future.
Posted May 17, 2025 - 14:31 EDT

Identified

We are aware of an issue with Facebook Authentication being down. This is due to Meta's decision to terminate our page without reason. This service will remain down and inaccessible for the foreseeable future.
Posted May 02, 2025 - 18:48 EDT
This incident affects: Lake Tails Grooming Solutions (Authentication).